Displaying all 9 Articles

Tracking the robot

If visualizers are turned on (’Render’ menu ! ’Visualizers’), we can use them to see the path our robot has travelled.  To track the robot’s movement, follow these steps!: 1. Click on the Objects toolbar button. 2. Select the robot from the list. 3. Right click to bring up a context menu for the object, choose "Track Movement". 4. Start the simulator, by pressing the Play button.                                                                                                                            Tracking the robot We’ll note that with the simulator running we can now drive the robot using the W,A,S,D keyboard keys, and a blue line will be drawn behind the robot as it travels.                                                                                                               Robot leaving behind "Breadcrumb" The "Breadcrumb" or track that the robot leaves behind, can be cleared by right clicking on the robot in the Objects window and choosing to "stop tracking" and then clicking again to "clear tracks".

Using Attachments

Many of the sample project robots come with additional components that can be added. To see a listing of available attachments for the sample project robot, select the robot by either clicking on it in the Objects window, or by clicking the Move  button located on the toolbar, then clicking on the robot in the Main Camera. With the robot selected, click on the Attachments  button located on the Toolbar.                                                                                                                       Adding attachments After clicking on the Attachments button, a new window will appear. To add a new attachment, select it from the list of "Available Attachments", choose a position on the robot, and then click "Add".                                                                                             Adding an attachment Similarly, you can remove an existing attachment by selecting it from the "Current Attachments" list, and clicking on the "Remove" button.                                                                                                                                  Removing an attachment When finished, click the "Ok" button to save your changes.

What is LDraw?

LDraw is a popular CAD format for sharing 3D LEGO models. The simulator is capable of parsing an imported (*.ldr) file, and then assigning physical attributes to it such as weight, centre of mass, and collision data to each model element. If you haven’t already done so, you should consider downloading and installing the LDraw "All in One" installer, as it will greatly expand the number of bricks that the simulator can work with.                                                                   http://www.ldraw.org/help/gettingstarted.html After installing the ’All-in-One’ library, you will also want to update LEGO Digital Designer so that you can export your models to the sim. This can be achieved by clicking on Help menu and selecting Patch LEGO Digital Designer.                                                                                   Applying the patch for LEGO Digital Designer

Introducing LEGO Digital Designer

Você pode baixar o LEGO® Digital Designer ™ (LDD) clicando no link abaixo:                                     Http://www.lego.com/en-us/MINDSTORMS/downloads O LDD é uma ferramenta muito fácil de usar do ponto de vista do autor. A documentação de "Ajuda" no LDD dá-lhe uma base muito boa para começar a construir os seus próprios modelos. A melhor parte do uso do LDD pode ser usada para criar modelos de simuladores exportáveis, bem como uma lista de materiais e instruções de construção imprimíveis para criar um robô físico.                                                                                                                                                                                                                                               Designer de LEGO Digital                                                                                      Crie instruções imprimíveis usando o modo de guia de construção do LDD                                                                                Lista de materiais criados a partir do LEGO Digital Designer

Installing LDD & LDraw

The installation process of LEGO Digital Designer and LDraw is quite simple. Go to the official LEGO Digital Designer website http://ldd.lego.com/en-us/. Click the Download button and select the platform you want to Windows or Mac to download the application. After that, follow the prompts in the setup wizard, accept the license terms, click Next, configure your shortcuts, click Next again, and follow the prompts. In order to transfer your simulator model successfully, you need to install the Ldraw track library. For this reason, go to the download link: http://www.ldraw.org/ and download the Ldraw All-In-One installer. This thing is part of a monster file, so you must be very patient to download it. Then, enter the captcha code to prove that you are not a robot, click Submit and have yourself a cup of coffee. Now follow the prompts in the Setup Wizard. There are a few options that need to be configured. For this reason, accept the license terms and change several installation options. We will continue to keep LDview, although we will choose ML Cad, an alternative to the LEGO Digital Designer, and allow you to preview the exported models. Deselect LPUB and uncheck the official LEGO models, so that you will not work with them, and then click Next. Enter the path to the ldraw installation. Select the shortcuts you want to use and click Next. The last interesting thing is to use LDView to create thumbnails. The exported models are an incredibly useful tool for previewing from LEGO Digital Designer. By previewing the model in LDView, you can be assured that your model is exported correctly. If not, there will be missing parts in the model. Before you go, go to the Preferences menu in the Virtual Robot Toolbox, click the Path tab, and make sure the simulator can find the Ldraw folder. If you can see the path to LDraw in the box, click the Browse button and navigate to the path that you set up your Ldraw library. It is usually installed under C:\Program Files(x86)\LDraw. To synchronize the LEGO Digital Designer (LDD) with LDraw and the simulator, click on the Help menu in the VRT and install the Lego Digital Designer program. This will allow LDD to transfer models to SIM. This briefly outlines the installation process of the Lego Digital Designer and LDraw track library.

Alternate Design Tools

The simulator can also work with models that are created using tools like MLCAD, LDCAD etc which are capable of exporting files to LDraw format (*.ldr). MLCad - MLCAD was at a time the standard for building LEGO models in LDraw format. It is built with aspects of a professional CAD tool, with three orthogonal views and one 3D perspective view.  LDCad - A newer tool than MLCad. It can do most of what MLCad can do, but has the advantage that editing can be done directly in the 3D view, and it has parts snapping. This one is closest to the experience you get in LEGO Digital Designer.

Importing models

The sequence of actions for importing an LDraw model in the simulator will be shown. 1. In the simulator, click the Help menu and select a patch for the LEGO® digital designer ™. 2. In the LEGO digital designer, click on the "File" menu and select "Export Model". 3. When prompted, select LDraw (* .ldr) in the list of exported file formats and place to save the file. 4. Open the simulator, and select the cleanup call. 5. Click the move object button and select the robot. With the robot selected, press the Delete key to remove it from the model space. 6. We now have to look at a project that does not have robots in it. 7. To import our custom robot in the simulator, click on the environment menu and select "Import model ..." 8. This will launch the LDraw Simulator Import Wizard. 9. After import, the simulator analyze the model to determine which components are rigidly connected (i.e., the connector pegs, and the elements that make up the  chassis) and the components of which are free movement (i.e. wheels on the robot). 10. Next, the import wizard will identify specific components, such as motors and sensors. The user will be prompted to assign these special components to the ports  on the intelligent bricks, so that they can be subsequently monitored by LEGO®  mindstorms® with the programming environment. 11. С моторами и датчиками, подключенный к соответствующим портам, пользователю будет предложено назначить клавиши управления для вождения робота. Будучи в состоянии взять робота на тест-драйв в симуляторе, чтобы увидеть, как он ручками может быть особенно ценным инструментом для соревновательной робототехники команд, прежде чем инвестировать много времени и усилий на программирование робота для выполнения задачи. 12. Модели будет завершена, и пользователю будет предложено нажать кнопку "ОК", чтобы закрыть мастер. 13. Робот появится в центре файл проекта, нажав на кнопку play для начала тренажер позволяет нам наше творение с помощью клавиатуры, которые мы назначили. 14. As a curiosity, select the imported robot using the move object tool. Click on the Render menu and make sure that “Physics” is being checked. Note that now the  imported model glows like a Christmas tree! This is because the model now  contains intelligence; it is no longer just “unusual” photos.

Support